OS-7838: mapfile name for unix should be less generic


Issue Type:Improvement
Priority:4 - Normal
Created at:2019-06-13T15:51:14.274Z
Updated at:2020-10-16T20:21:43.908Z


Created by:Former user
Reported by:Former user
Assigned to:Former user


Fixed: A fix for this issue is checked into the tree and tested.
(Resolution Date: 2019-06-13T17:57:14.004Z)

Fix Versions

2019-06-20 Urban Fervor (Release Date: 2019-06-20)

Related Issues


While addressing OS-7835, I discovered that all of the uts/*/unix Makefiles use the generic MAPFILE name to build the unix module, rather than something more specific. This gets in the way of other machine-specific modules using such a name that makes sense. The variable for the unix mapfile should probably be renamed to UNIX_MAPFILE.


Comment by Former user
Created at 2019-06-13T17:14:18.788Z

To test this, I initiated a new build of the uts/i86pc/unix component and checked to make sure the appropriate mapfile was passed to ld(1) via -M. After performing the build, I booted up on the resulting PI and verified that it does boot and operate as expected.

Comment by Jira Bot
Created at 2019-06-13T17:44:27.397Z

illumos-joyent commit 1f79f23316512a7271211767a997ac719da76e1e (branch master, by Patrick Mooney)

OS-7838 mapfile name for unix should be less generic
Reviewed by: Robert Mustacchi <robert.mustacchi@joyent.com>
Reviewed by: John Levon <john.levon@joyent.com>
Approved by: John Levon <john.levon@joyent.com>