SVCADM(8) Maintenance Commands and Procedures SVCADM(8)

NAME


svcadm - manipulate service instances

SYNOPSIS


/usr/sbin/svcadm [-S state] [-v] [-Z | -z zone] enable [-rst]
[{FMRI | pattern}...]


/usr/sbin/svcadm [-S state] [-v] [-Z | -z zone] disable
[-c comment] [-st] [{FMRI | pattern}...]


/usr/sbin/svcadm [-S state] [-v] [-Z | -z zone] restart [-d]
[{FMRI | pattern}...]


/usr/sbin/svcadm [-S state] [-v] [-Z | -z zone] refresh
[{FMRI | pattern}...]


/usr/sbin/svcadm [-S state] [-v] [-Z | -z zone] clear
[{FMRI | pattern}...]


/usr/sbin/svcadm [-S state] [-v] [-Z | -z zone] mark [-It] instance_state
[{FMRI | pattern}...]


/usr/sbin/svcadm [-v] milestone [-d] milestone_FMRI


DESCRIPTION


svcadm issues requests for actions on services executing within the
service management facility (see smf(7)). Actions for a service are
carried out by its assigned service restarter agent. The default service
restarter is svc.startd (see svc.startd(8)).

OPTIONS


The following options are supported:

-S state
For the subcommands which normally operate on
explicit FMRIs or an FMRI pattern, the -S option can
be used to select all FMRIs in the given state.


-v
Print actions verbosely to standard output.


-Z
Administer services in all zones. This option is
only applicable from the global zone, see zones(7).


-z zone
Administer services in the specified zone. This
option is only applicable from the global zone, see
zones(7).


SUBCOMMANDS


Common Operations


The subcommands listed below are used during the typical administration
of a service instance.


For subcommands taking one or more operands, if the operand specifies a
service (instead of a service instance), and that service has only a
single instance, svcadm operates on that instance. If an abbreviated FMRI
(a fault management resource identifier) matches more than one service or
instance, a warning message is displayed and that operand is ignored. If
a pattern matches more than one service or instance, the subcommand is
applied to all matches. See smf(7).


In the case that the service has more than one instance, svcadm return a
non-zero exit status.

enable [-rst] {FMRI | pattern}...

Enables the service instances specified by the operands. For each
service instance, the assigned restarter will try to bring it to the
online state. This action requires permission to modify the "general"
property group of the service instance (see smf_security(7)).

If the -r option is specified, svcadm enables each service instance
and recursively enables its dependencies.

If the -s option is specified, svcadm enables each service instance
and then waits for each service instance to enter the online or
degraded state. svcadm will return early if it determines that the
service cannot reach these states without administrator intervention.

If the -t option is specified, svcadm temporarily enables each
service instance. Temporary enable only lasts until reboot. This
action requires permission to modify the "restarter_actions" property
group of the service instance (see smf_security(7)). By default,
enable is persistent across reboot.


disable [-c comment] [-st] {FMRI | pattern}...

Disables the service instance specified by the operands. For each
service instance, the assigned restarter will try to bring it to the
disabled state. This action requires permission to modify the
"general" property group of the service instance (see
smf_security(7)).

If the -s option is specified, svcadm disables each service instance
and then waits for each service instance to enter the disabled state.
svcadm will return early if it determines that the service cannot
reach this state without administrator intervention.

If the -t option is specified, svcadm temporarily disables each
service instance. Temporary disable only lasts until reboot. This
action requires permission to modify the "restarter_actions" property
group of the service instance (see smf_security(7)). By default,
disable is persistent across reboot.

If the -c option is specified, the given free-form comment is
recorded in the (temporary) service configuration under the
general/comment property. This can serve as an administrator reason
for disabling the service, and is reported by svcs(1).


restart [-d] {FMRI | pattern}...

Requests that the service instances specified by the operands be
restarted. This action requires permission to modify the
"restarter_actions" property group of the service instance (see
smf_security(7)).

This subcommand can restart only those services that are in the
online or degraded states, as those states are defined in smf(7).

If the -d option is specified, the restarter sends a SIGABRT to all
members of the contract, which should cause a core dump, before
restarting the service.


refresh {FMRI | pattern}...

For each service instance specified by the operands, requests that
the assigned restarter update the service's running configuration
snapshot with the values from the current configuration. Some of
these values take effect immediately (for example, dependency
changes). Other values do not take effect until the next service
restart. See the restarter and service documentation for more
information.

If the service is managed by svc.startd(8), the refresh method will
be invoked if it exists to request the service reread its own
configuration. For other restarters, see the restarter documentation.

This action requires permission to modify the "restarter_actions"
property group of the service instance (see smf_security(7)).


clear {FMRI | pattern}...

For each service instance specified by the operands, if the instance
is in the maintenance state, signal to the assigned restarter that
the service has been repaired. If the instance is in the degraded
state, request that the assigned restarter take the service to the
online state. This action requires permission to modify the
"restarter_actions" property group of the service instance (see
smf_security(7)).


Exceptional Operations


The following subcommands are used for service development and temporary
administrative manipulation.

mark [-It] instance_state {FMRI | pattern}...

If instance_state is "maintenance", then for each service specified
by the operands, svcadm requests that the assigned restarter place
the service in the maintenance state. See svc.startd(8) and inetd(8)
for a detailed description of the actions taken for each restarter.

If instance_state is "degraded", then for services specified by the
operands in the online state, svcadm requests that the restarters
assigned to the services move them into the degraded state.

If the -I option is specified, the request is flagged as immediate.

The -t option is only valid for maintenance requests. When this
option is specified, the request is flagged as temporary, and its
effect will only last until the next reboot.


milestone [-d] milestone_FMRI

If milestone_FMRI is the keyword "none", all services other than the
master restarter, svc:/system/svc/restarter:default, will be
temporarily disabled.

If milestone_FMRI is the keyword "all", temporary enable and disable
requests for all services will be nullified.

If milestone_FMRI is one of the following:

svc:/milestone/single-user:default
svc:/milestone/multi-user:default
svc:/milestone/multi-user-server:default


then temporary enable and disable requests for the indicated service
and all services it depends on (directly or indirectly) will be
nullified. All other services will be temporarily disabled.

Changing the system's current milestone with the "milestone"
subcommand will not change the current run level of the system. To
change the system's run level, invoke /sbin/init directly.

This action requires permission to modify the "options_ovr" property
group of the svc:/system/svc/restarter:default service instance (see
smf_security(7)).

The -d option immediately changes the milestone to the requested
milestone, as above. Additionally, it makes the specified milestone
the default boot milestone, which persists across reboot. The default
milestone is defined by the options/milestone property on the master
restarter, svc:/system/svc/restarter:default. If this property is
absent, "all" is the default. This action requires permission to
modify the "options" property group of the
svc:/system/svc/restarter:default service instance (see
smf_security(7)).


Operands


The following operands are supported:

FMRI
An FMRI that specifies one or more instances. FMRIs can be
abbreviated by specifying the instance name, or the trailing
portion of the service name. For example, given the FMRI:

svc:/network/smtp:sendmail


All the following are valid abbreviations:

sendmail
:sendmail
smtp
smtp:sendmail
network/smtp


While the following are invalid:

mail
network
network/smt


If the FMRI specifies a service, then the command applies to
all instances of that service. Abbreviated forms of FMRIs are
unstable, and should not be used in scripts or other permanent
tools.


pattern
A pattern that is matched against the FMRIs of service
instances according to the "globbing" rules described by
fnmatch(7). If the pattern does not begin with "svc:", then
"svc:/" is prepended.


If an abbreviated FMRI matches more than one service, a warning message
is displayed and that operand is ignored. If a pattern matches more than
one service or instance, the subcommand is applied to all matches.

EXAMPLES


Example 1: Restarting a Service Instance




The following command restarts the NFS server. The full FMRI for the
default service instance is: svc:/network/nfs/server:default


However, you can abbreviate the full FMRI as follows:


# svcadm restart nfs/server


Example 2: Disabling a service




The following command synchronously disables a service, using an
abbreviated FMRI, and recording a ticket ID as the administrative reason:


$ svcadm disable -c "OPS-1000" -s http


Example 3: Enabling an Instance and Its Dependent Instances




The following command enables the foo:bar instance, and all instances on
which it depends:


$ svcadm enable -r foo:bar


Example 4: Synchronously enabling an instance




The following command enables the foo:bar instance. The command will not
return until the instance comes online or svcadm determines it is not
possible for the service to come online.


$ svcadm enable -s foo:bar


Example 5: Restricting and Restoring the Running Services




The following command restricts the running services to single user mode:


# svcadm milestone milestone/single-user


The following command restores the running services:


# svcadm milestone all


EXIT STATUS


The following exit values are returned:

0
Successful completion.


1
A fatal error occurred. One or more error messages are displayed on
standard error.


2
Invalid command line options were specified.


3
svcadm determined that a service instance that it was waiting for
could not reach the desired state without administrator intervention
due to a problem with the service instance itself.


4
svcadm determined that a service instance that it was waiting for
could not reach the desired state without administrator intervention
due to a problem with the service's dependencies.


ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | See below. |
+--------------------+-----------------+


The interactive output is Uncommitted. The invocation and non-interactive
output are Committed.

SEE ALSO


svcprop(1), svcs(1), libscf(3LIB), contract(5), attributes(7), smf(7),
smf_security(7), zones(7), inetd(8), init(8), svc.startd(8), svccfg(8)

NOTES


The amount of time svcadm will spend waiting for services and their
dependencies to change state is implicitly limited by their method
timeouts. For example, a service using the default restarter whose start
method hangs will be transitioned to the maintenance state when its
timeout expires. svcadm will then consider it impossible for this
service to come online without administrator intervention.


Attempts to synchronously enable a service which depends (directly or
indirectly) on a file may fail with an exit status indicating that
dependencies are unsatisfied if the caller does not have the privileges
necessary to search the directory containing the file. This limitation
may be removed in a future release.

May 11, 2020 SVCADM(8)