NET_GETNETID(9F) Kernel Functions for Drivers NET_GETNETID(9F)

NAME


net_getnetid - returns the instance identifier

SYNOPSIS


#include <sys/neti.h>

netid_t net_getnetid(const net_data_t net);


INTERFACE LEVEL


illumos DDI specific (illumos DDI).

PARAMETERS


net
value returned from a successful call to net_protocol_lookup(9F).


DESCRIPTION


The net_getnetid() function returns the instance identifier for the
protocol instance returned via a call to net_protocol_lookup(9F).

RETURN VALUES


The net_getnetid() function returns the value of the instance identifier.

CONTEXT


The net_getnetid() function may be called from user, kernel, or
interrupt context.

ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Committed |
+--------------------+-----------------+

SEE ALSO


net_protocol_lookup(9F)

May 1, 2008 NET_GETNETID(9F)