NET_GETPMTUENABLED(9F) Kernel Functions for Drivers NET_GETPMTUENABLED(9F)

NAME


net_getpmtuenabled - determine if path MTU discovery is enabled for a
network protocol

SYNOPSIS


#include <sys/neti.h>

int net_getpmtuenabled(const net_data_t net);


INTERFACE LEVEL


illumos DDI specific (illumos DDI).

PARAMETERS


net
value returned from a successful call to net_protocol_lookup(9F).


DESCRIPTION


The net_getpmtuenabled() function returns a value to indicate whether or
not path MTU (PMTU) discovery is enabled for this network protocol.

RETURN VALUES


The net_getpmtuenabled() function returns:

-1
The network protocol does not support this function.


0
PATH MTU discovery is disabled.


1
PATH MTU discovery is enabled.


CONTEXT


The net_getpmtuenabled() function may be called from user, kernel, or
interrupt context.

ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Committed |
+--------------------+-----------------+

SEE ALSO


net_getmtu(9F), net_protocol_lookup(9F)

May 1, 2008 NET_GETPMTUENABLED(9F)