NET_HOOK_UNREGISTER(9F) Kernel Functions for Drivers NET_HOOK_UNREGISTER(9F)

NAME


net_hook_unregister - disable a hook that was called in event processing

SYNOPSIS


#include <sys/neti.h>

int net_hook_unregister(const net_data_t net, nethook_t hook);


INTERFACE LEVEL


illumos DDI specific (illumos DDI).

PARAMETERS


net
value returned from a successful call to net_protocol_register().


hook
value returned from a successful call to net_hook_register(9F).


DESCRIPTION


The net_hook_unregister() function disables the callback hooks that were
registered with the net_hook_register() function.

RETURN VALUES


If the net_hook_unregister() function succeeds, 0 is returned. Otherwise,
an error indicating the problem encountered.

CONTEXT


The net_hook_unregister() function may be called from user, kernel, or
interrupt context.

ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Committed |
+--------------------+-----------------+

SEE ALSO


net_hook_register(9F)

May 1, 2008 NET_HOOK_UNREGISTER(9F)