NET_INJECT_ALLOC(9F) Kernel Functions for Drivers NET_INJECT_ALLOC(9F)

NAME


net_inject_alloc - allocate a net_inject_t structure

SYNOPSIS


#include <sys/neti.h>

net_inject_t *net_inject_alloc(const int version);


INTERFACE LEVEL


illumos DDI specific (illumos DDI).

PARAMETERS


version
must always be the symbol NETI_VERSION.


DESCRIPTION


The net_inject_alloc() function allocates a net_inject_t structure,
returning a pointer for the caller to use.

RETURN VALUES


Upon success, net_inject_alloc() returns a pointer to the allocated
net_inject_t structure. On failure, hook_alloc() returns a NULL pointer.

CONTEXT


The net_inject_alloc() function may be called from user, kernel, or
interrupt context.

ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Committed |
+--------------------+-----------------+

SEE ALSO


net_inject_free(9F), net_inject_t(9S)

May 1, 2008 NET_INJECT_ALLOC(9F)