NET_KSTAT_DELETE(9F) Kernel Functions for Drivers NET_KSTAT_DELETE(9F)

NAME


net_kstat_delete - remove a kstat for a specific instance of IP from the
system

SYNOPSIS


#include <sys/types.h>
#include <sys/kstat.h>
#include <sys/neti.h>

void net_kstat_delete(netid_t netid, kstat_t *ksp);


INTERFACE LEVEL


illumos DDI specific (illumos DDI).

PARAMETERS


netid
IP instance identifier.


ksp
Pointer to a currently installed kstat(9S) structure.


DESCRIPTION


The net_kstat_delete() function removes ksp from the kstat chain and
frees all associated system resources. See kstat_delete(9F) for a
complete discussion of this function.

RETURN VALUES


If successful, net_kstat_delete() returns a pointer to the allocated
kstat. NULL is returned upon failure.

CONTEXT


The net_kstat_delete() function may be called from user, kernel, or
interrupt context.

ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Committed |
+--------------------+-----------------+

SEE ALSO


kstat_create(9F), kstat_delete(9F), net_kstat_create(9F), hook_t(9S),
kstat_named(9S)

May 1, 2008 NET_KSTAT_DELETE(9F)