NET_NETIDTOZONID(9F) Kernel Functions for Drivers NET_NETIDTOZONID(9F)

NAME


net_netidtozonid - map a netid_t structure identifier to a zoneid_t
structure

SYNOPSIS


#include <sys/neti.h>

zoneid_t net_netidtozonid(const netid_t net);


INTERFACE LEVEL


illumos DDI specific (illumos DDI).

PARAMETERS


net
valid netid_t structure that refers to an existing IP instance.


DESCRIPTION


The net_netidtozonid() function maps the given netid_t (used to represent
an instance of IP) into the matching zoneid_t structure that is
associated with it.

RETURN VALUES


The net_netidtozonid() function returns -1 if no mapping took place.
Otherwise, it returns the zoneid_t structure currently associated with a
netid_t structure. For shared stack zones, the zoneid_t structure for the
global zone is returned.

CONTEXT


The net_netidtozonid() function may be called from user, kernel, or
interrupt context.

ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Committed |
+--------------------+-----------------+

SEE ALSO


attributes(7), net_zoneidtonetid(9F)

May 1, 2008 NET_NETIDTOZONID(9F)