NET_PROTOCOL_RELEASE(9F) Kernel Functions for Drivers NET_PROTOCOL_RELEASE(9F)

NAME


net_protocol_release - indicate that a reference to a network protocol is
no longer required

SYNOPSIS


#include <sys/neti.h>

int net_protocol_release(net_handle_t info);


INTERFACE LEVEL


illumos DDI specific (illumos DDI).

PARAMETERS


info
value returned from a successful call to net_protocol_lookup(9F).


DESCRIPTION


The net_protocol_release() function indicates to the network information
framework that the caller is no longer interested in any knowledge about
the network protocol to which the parameter being passed through applies.

RETURN VALUES


The net_protocol_release() function returns:

-1
The value passed in is unknown to this framework.


0
Successful completion.


1
Unsuccessful because this function has been called too many times.


CONTEXT


The net_protocol_release() function may be called from user, kernel, or
interrupt context.

ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Committed |
+--------------------+-----------------+

SEE ALSO


attributes(7), net_protocol_lookup(9F), net_protocol_walk(9F)

March 5, 2012 NET_PROTOCOL_RELEASE(9F)