NET_ROUTETO(9F) Kernel Functions for Drivers NET_ROUTETO(9F)

NAME


net_routeto - indicate which network interface packets are sent

SYNOPSIS


#include <sys/neti.h>

phy_if_t net_routeto(const net_data_t *net, struct sockaddr *address,
struct sockaddr *nexthop);


INTERFACE LEVEL


illumos DDI specific (illumos DDI).

PARAMETERS


net
value returned from a successful call to
net_protocol_lookup(9F).


address
network address to find a path out of the machine for.


nexthop
pointer to the sockaddr structure in which to store the
address of the next hop. If this information is not required,
the value NULL may be passed instead.


DESCRIPTION


The net_routeto() function indicates which network interface packets
destined for a particular address would be sent out of, according to the
systems network routing tables. If next is supplied as a non-NULL
pointer, the IP address of the nexthop router to be used is returned in
it.

RETURN VALUES


The net_routeto() function returns:

-1
The network protocol does not support this function.


0
This function cannot find a route for the address given.


>0
Indicates which network interface can be used to reach the given
address.


CONTEXT


The net_routeto() function may be called from user, kernel, or interrupt
context.

ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Committed |
+--------------------+-----------------+

SEE ALSO


attributes(7), net_phygetnext(9F), net_phylookup(9F),
net_protocol_lookup(9F)

May 1, 2008 NET_ROUTETO(9F)