NET_INSTANCE_ALLOC(9F) Kernel Functions for Drivers NET_INSTANCE_ALLOC(9F)

NAME


net_instance_alloc - allocate a net_instance_t structure

SYNOPSIS


#include <sys/neti.h>

net_instance_t *net_instance_alloc(const int version);


INTERFACE LEVEL


illumos DDI specific (illumos DDI).

PARAMETERS


version
must always be the symbol NETINFO_VERSION.


DESCRIPTION


The net_instance_alloc() function allocates a net_instance_t structure,
returning a pointer for the caller to use.

RETURN VALUES


Upon success, net_instance_alloc() returns a pointer to the allocated
net_instance_t structure. On failure, it returns a NULL pointer.

CONTEXT


The net_instance_alloc() function may be called from user or kernel
context.

ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Committed |
+--------------------+-----------------+

SEE ALSO


attributes(7), net_instance_free(9F), net_inject_t(9S)

March 5, 2012 NET_INSTANCE_ALLOC(9F)