NET_INSTANCE_FREE(9F) Kernel Functions for Drivers NET_INSTANCE_FREE(9F)

NAME


net_instance_free - free a net_instance_t structure

SYNOPSIS


#include <sys/neti.h>

void net_instance_free(net_instance_t *net_instance);


INTERFACE LEVEL


illumos DDI specific (illumos DDI).

PARAMETERS


net_instance
pointer returned by net_instance_alloc(9F).


DESCRIPTION


The net_instance_free() function frees a net_instance_t structure that
was originally allocated by net_instance_alloc(9F).

CONTEXT


The net_instance_free() function may be called from user, kernel, or
interrupt context.

ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Committed |
+--------------------+-----------------+

SEE ALSO


attributes(7), net_instance_alloc(9F), net_instance_t(9S)

May 1, 2008 NET_INSTANCE_FREE(9F)